org.eclipse.gef 0.0.0

When trying to install the Installing Google GAE or Android eclipse plugins on Ubuntu I was getting the following error message:

… requires ‘org.eclipse.gef 0.0.0’ but it could not be found

I had installed eclipse using the ubuntu software center and wrongfully assumed it would include this emf and gef frameworks as default (i later found these are included by default across all platforms).

On Eclipse 3.5  galileo goto Help>Install new software and add  http://download.eclipse.org/releases/galileo to your update sites and try again.